Access to Plume Backend tools is disrupted

Incident Report for EU Theta Production Cloud

Resolved

The responsiveness of the Plume Portal, Frontline, and all other tools affected by this outage has returned to normal. This issue is now considered resolved, although we will continue to monitor for any changes.
Posted Oct 20, 2025 - 20:52 UTC

Monitoring

A fix has been implemented and we’re seeing signs of recovery. A small number of requests to the services are seeing slower response times. We’re continuing to monitor and will update when all concerns are completely resolved.
Posted Oct 20, 2025 - 18:29 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 15:38 UTC

Investigating

Service access has been disrupted since 2025-10-20 8:43 UTC. Users might experience trouble accessing Frontline Tier 1 and 2&3, Signal, Panorama, Plume Academy and backend support tools used for monitoring and onboarding. Plume's engineering team is investigating the issue and working on a correction.
Posted Oct 20, 2025 - 15:38 UTC